Introduction

 |  | Net Accelerator Version 5.0
Net Accelerator is an Internet solution, which easily solves two of the most well known Internet problems: Slow connection performances and Undesirable disconnections.
General Information
 | Net Accelerator Overview
 | Technical Support and Upgrades
 | Frequently Asked Questions
Using Net Accelerator
 | General Settings
 | Advanced Settings
 | Ping Configuration
License Agreement

Copyright © 2000-2001 Rizal Software Inc.


Net Accelerator Overview
 | Net Accelerator is an Internet solution, which easily solves two of the most well known Internet problems: Slow connection performances and Undesirable disconnections.
 | Net Accelerator can prevent TCP/IP protocols data transfer from fragmentation. By using it you can boost your Internet connection performances up to 200% (we also got users’ reports on 300% improvement).
 | Net Accelerator has also a Ping option which prevents you from being disconnected by your ISP (Internet Service Provider). Most Internet Service Providers have inactivity timeout, they will disconnect you after a fixed time of modem inactivity. How many times did you leave your computer for a few minutes and the moment you came back you found out that somehow you had been disconnected? How many times did you decide to read something on the net and before finishing it the disconnect dialog appeared? Net Accelerator will prevent those undesirable disconnections by sending and receiving a data package every fixed time.
 | Net Accelerator saves a lot of time, money and frustrations. It’s a MUST HAVE tool for everyone who uses an Internet connection. It boosts any Internet related software such as browser/email programs, AOL, CompuServe, RealAudio, Real Video, ICQ and many others… Moreover it also prevents an undesirable disconnection.
 | Net Accelerator is being used by people all over the world and the reviews are amazing. It Includes a very intuitive and simple to operate user interface and a comprehensive help file.


Features

Feature Highlights
 | Supports all software and hardware adapters.
 | Easily restores the default Windows settings.
 | Two automatic modes to configure Dial-Up and LAN settings.
 | A manual mode to configure Dial-Up and LAN settings.
 | Includes easy registry backup.
 | Fix MaxMTU, RWIN, TTL, Session Keep Alive, PMTU and NDI Cache.
 | Prevent you from being disconnected by your ISP (Internet Service Provider).
 | You have full control over the Ping Interval, Ping Host and Ping Sound.
 | A build in Automatic Ping mode.
Includes a comprehensive help file.
Supports Windows 95/98/Me/NT/2000/XP.


Tips and Tricks

Tips & Tricks
MTU is the default packet size that Windows uses to negotiate with. If MTU is set too large, the routers fragment into a packet size that the router can handle. This fragmentation can double the amount of time it takes to send a single packet.
The TCP Receive Window size is the amount of receive data (in bytes) that can be buffered at one time on a connection.
TTL is a field in the IP header which indicates how long a packet should be allowed to survive before it is discarded.
Session Keep Alive specifies how often to send session keep alive packets on active sessions.
Enabling Path MTU Auto Discovery causes TCP to attempt to discover the Maximum Transmission Unit (MTU or largest packet size) over the path to a remote host.
Black Hole Routers Detect specifies whether the stack will attempt to detect Maximum Transmission Unit (MTU) routers that do not send back ICMP fragmentation-needed messages.
NDI Cache is the size of the cache used to store source routing paths. It has a very large effect on the performance of your TCP connection.
The HTTP 1.1 specification mandates the two connection limit and HTTP 1.0 specification mandates the four connection limit.
Most Internet Service Providers have inactivity timeout, they will disconnect you after a fixed time of modem inactivity.


Net Accelerator - General

General
Net Accelerator can improve your connection speed no matter what type of connection you are using (Dialup, DSL, LAN, Cable etc.).
It’s very hard to configure your connection automatically because there are a lot of different hardware vendors in the market and each computer is a little bit different than the other. After choosing your configuration, Please click on the ‘Apply’ button.
Automatic optimization modes (Automatic #1, Automatic #2, Automatic #3):
After a lot of research, Net Accelerator offers three different Automatic Optimization Modes which will improve your connection speed. You should try all three of them to find out which Automatic Optimization Mode suits your hardware configuration best. If you are unsatisfied with the three automatic optimization modes results you may try the manual mode.
Manual optimization mode:
Since each system is different, there aren’t fixed rules. If you don’t obtain satisfactory results with the Automatic Optimization Modes, you should try various setting combinations. Watch your Internet performance to find out which configuration suits your hardware configuration best.
MTU (Maximum Transmission Unit):
 | This is the default packet size that Windows uses to negotiate with. When a connection is opened between two computers, they must agree on an MTU. It’s done by comparing MTU and selecting the smaller of the two. If the MTU is set too large for routers that are between the computers, these routers then fragment this information into a packet size that the router can handle. This fragmentation can double the amount of time it takes to send a single packet.
 | Windows has a built-in MTU Discovery that will adjust for this by sending out a packet that is marked as "Not Fragmental". Then the router sends back an error to the computer saying that the packet was too large, and Windows then lowers the MTU until there are no more errors.
 | If your ISP uses an MTU of 576, then every time you start a connection, Windows must adjust down to this value. Even though Windows automatically adjusts the packet size, it still takes it time to negotiate an acceptable MTU. By setting this value manually, you greatly reduce the amount of work that Windows must do to negotiate.
RWIN (Receive Window):
 | This is the default packet size that Windows uses to negotiate with. When a connection is opened between two computers, they must agree on an MTU. It’s done by comparing MTU and selecting the smaller of the two. If the MTU is set too large for routers that are between the computers, these routers then fragment this information into a packet size that the router can handle. This fragmentation can double the amount of time it takes to send a single packet.
 | Windows has a built-in MTU Discovery that will adjust for this by sending out a packet that is marked as "Not Fragmental". Then the router sends back an error to the computer saying that the packet was too large, and Windows then lowers the MTU until there are no more errors.
 | If your ISP uses an MTU of 576, then every time you start a connection, Windows must adjust down to this value. Even though Windows automatically adjusts the packet size, it still takes it time to negotiate an acceptable MTU. By setting this value manually, you greatly reduce the amount of work that Windows must do to negotiate.
TTL (Time To Live):
 | TTL is a field in the IP header which indicates how long a packet should be allowed to survive before it is discarded. This value specifies the maximum number of routers that a packet may be forwarded through on to its destination. TTL essentially determines the maximum number of hops permitted.
 | Windows 95 default is 32, but with the Internet growing larger all the time, we recommend to set it to the larger setting of 128.


Advanced Options
Session Keep Alive:
 | Specifies how often to send session keep alive packets on active sessions. This will keep connections that have stalled during a particular download session from timing out.
 | Windows default value is 60 minutes, we recommend to set it to 10 minutes.
NDI Cache:
 | NDI Cache is the size of the cache used to store source routing paths. It has a very large effect on the performance of your TCP connection.
 | If your MAXMTU is set to 576 or below, it’s recommended to set the NDI Cache to 16. If your MAXMTU value is greater than 576 set your NDI Cache to 32.
Maximum Sessions Allowed:
 | Windows limits connections to a single HTTP 1.0 server to four simultaneous connections. Connections to a single HTTP 1.1 server will be limited to two simultaneous connections. The HTTP 1.1 specification (RFC2068) mandates the two connection limit while the four connection limit for HTTP 1.0 is a self-imposed restriction which coincides with the standard used by a number of popular Web browsers.
 | Use this option in order to increase the number of simultaneous downloads from the same web site.
MTU Auto Discover:
 | Enabling this setting causes TCP to attempt to discover the Maximum Transmission Unit (MTU or largest packet size) over the path to a remote host. By discovering the Path MTU and limiting TCP segments to this size, TCP is supposed to be able to eliminate fragmentation at routers along the path that connect networks with different MTUs. This requires implementation of the corresponding server side algorithm, however, and presupposes all of the servers on the entire Internet only running MSFT server software with server-side optimization features accessible from MSFT web-browser client software. Needless to say, this is rather unlikely.
 | Nevertheless, it is not recommended to disable this setting as it would then cause an MTU of 576 bytes to be used for all connections that are not to machines on the local subnet. Disabling this setting can cause severe performance degradation because fragmentation may not be compensated for.
 | MTU Auto Discover is Enabled by Default.
Black Hole Detection:
 | Black Hole Detection specifies whether the stack will attempt to detect Maximum Transmission Unit routers that do not send back ICMP fragmentation-needed messages. Enabling black hole detection increases the maximum number of re-transmissions performed for a given segment. Setting this parameter 'enabled', when it is not needed, can cause performance degradation. If the router is not sending back the ICMP messages, then PMTU will not work. This can cause an even greater loss of performance. It is recommended that PMTU Black Hole Detect be disabled.
 | Black Hole Detect is disabled by default.


Ping Configuration
Net Accelerator includes a Ping option which prevents you from being disconnected by your ISP (Internet Service Provider). Most Internet Service Providers have inactivity timeout, they will disconnect you after a fixed time of modem inactivity. With Net Accelerator no ISP will disconnect you because of modem inactivity.


Recommended Settings

Recommended Settings For Windows 95/98/98SE/ME/2000 and XP
The below settings are recommended for most computer users. Since there are literally thousands of different system configurations, we can not guarantee that any of these particular setting will boost your Internet connection. If you have tried the recommended setting for your connection type and noticed no speed improvement, we recommend you read the Help files and adjust your settings manually. It is highly recommended that you backup your Windows registry before continuing. If you have any suggestion or recommendation, please e-mail us.
Windows 95/98/98SE/ME Users:
 | Modem Connection I
 | MTU: 1500 RWIN: 2144 TTL : 64
 | Modem Connection II
 | MTU: 1500 RWIN: 3216 TTL : 64
 | Cable Modem/LAN I
 | MTU: 1500 RWIN: 8192 TTL : 64
 | DSL
 | MTU: 1500 RWIN: 32767 TTL : 128
 | Broadband
 | MTU: 1500 RWIN: 372300 TTL : 64
 | ISDN/T1/Satellite
 | MTU: 1500 RWIN: 372300 TTL : 64
Windows NT/2000/XP Users:
 | Modem Connection
 | MTU: 1500 RWIN: 372300 TTL : 128
 | Cable Modem/DSL/Broadband/ISDN/T1/Satellite
 | MTU: 1500 RWIN: 32767 TTL : 128

Note : Please restart your computer for changes to take affect !


Requirements
 | Windows 98/ME/NT/2000/XP
 | Pentium or higher processor
 | 16 MB of memory
 | 5 MB of available disk space
 | VGA or higher-resolution graphics card set to 64 K colors for best results
 | Mouse or compatible pointing device
 | VisualBasic6 Runtime You can download from the link http://download.microsoft.com/download/vb60pro/install/6/Win98Me/EN-US/VBRun60.exe


Frequantly Asked Questions

 Frequently Asked Questions

What is Net Accelerator?
Net Accelerator is a powerful, self installing program for Windows® 95, 98, NT, 2000, and ME which optimizes your Internet connection speed by up to 200%.

What does Net Accelerator do?
Net Accelerator saves a lot of time, money and frustrations. It’s a MUST HAVE tool for everyone who uses an Internet connection. It boosts any Internet related software such as browser/email programs, AOL, CompuServe, RealAudio, Real Video, ICQ and many others… Moreover it also prevents an undesirable disconnection.

Will Net Accelerator work on my system?
Net Accelerator is compatible with Windows® 95, 98, ME, NT, 2000, and XP.

Will Net Accelerator speed up any Internet connection?
Yes. Net Accelerator is designed to work with all dial up modems, cable modems, DSL, home or office connections. Net Accelerator optimizes even high speed connections to their maximum potential.

While starting the appllcation I got the message "A required DLL File Not found", What I have to do?
This Program requires VB Runtime Library if you don't have VB Runtime Library in your system then you will receive error "a required .DLL file, MSVBVM60.DLL, was not found"
Please Download the VisualBasic6 Runtime from this link.
http://download.microsoft.com/download/vb60pro/install/6/Win98Me/EN-US/VBRun60.exe


 Technical Support
We pride ourselves on having one of the best customer support systems
on the market. Please feel free to email us with any questions, or comments and
you will often get a response the same day.
Technical support can be obtained in several ways:
Email: NetAccelerator@rizalsoftware.com
Internet: http://www.rizalsoftware.com/NetAccelerator/
Access our home page: http://www.rizalsoftware.com/


License Agreement

End User License Agreement
Rizal Software Inc.
Copyright © 2000-2001 Rizal Software Inc.
All Rights Reserved

END USER LICENSE AGREEMENT (EULA):
NOTICE: Rizal Software Inc. LICENSES Net Accelerator TO YOU ONLY UPON THE CONDITION THAT YOU ACCEPT ALL OF THE TERMS CONTAINED IN THIS LICENSE AGREEMENT. PLEASE READ THESE TERMS CAREFULLY. IF YOU DO NOT AGREE TO THESE TERMS, THEN Rizal Software Inc. IS UNWILLING TO LICENSE THE SOFTWARE TO YOU, IN WHICH EVENT YOU SHOULD REMOVE THE FULL PRODUCT.
LICENSE AND WARRANTY:
The software which accompanies this license Net Accelerator is the property of Rizal Software Inc. or its licensers and is protected by copyright law. While Rizal Software Inc. continues to own the Net Accelerator software, you will have certain rights to use Net Accelerator after your acceptance of this license. Your rights and obligations with respect to the use Net Accelerator are as follows:

You May:
(i) | Install and use one copy of the SOFTWARE on a single computer.
(ii) | Make a copy of the SOFTWARE for archival purposes only.

You May Not:
(i) | Sublicense, rent, sell, or lease any portion of Net Accelerator.
(ii) | Charge, or request donations, for any copies of Net Accelerator , however made without prior permission.
(iii) | Recompile, disassemble, reverse engineer or modify the SOFTWARE or any portion of it, or make any attempt to bypass, unlock, or disable any protective or initialization system on the SOFTWARE.
(iv) | Include Net Accelerator together with any bundle of infringed copies.
(v) | Copy the documentation, which accompanies the Software without Rizal Software Inc. permission.
(vi) | Continue the usage of Net Accelerator after your 15 Days.
(vii) | Upload or transmit the SOFTWARE or any portion thereof, to any electronic bulletin board, network, or other type of multi-use computer system regardless of purpose.
(viii) | Include the SOFTWARE in any commercial products intended for manufacture, distribution, or sale. To request distribution authorization, please send your request via e-mail to {Support Email Address}.
(ix) | Copy and distribute the SOFTWARE or any portion of it except as expressly provided in this Agreement.

WARRANTY DISCLAIMER:
The SOFTWARE is supplied "AS IS". Rizal Software Inc. disclaims all warranties, expressed or implied, including, without limitation, and the warranties of merchantability and License of fitness for any purpose. The user must assume the entire risk of using this SOFTWARE.

DISCLAIMER OF DAMAGES:
 Regardless of whether any remedy set forth herein fails of its essential purpose, in no event will Rizal Software Inc. be liable to you for any special, consequential, indirect or similar damages, including any lost profits or lost data arising out of the use or inability to use the software even if Rizal Software Inc. has been advised of the possibility of such damages.

TERM:
This license is effective from your date of purchase and shall remain in force until terminated. You may terminate the license and this agreement at any time by destroying the SOFTWARE and its documentation, together with all copies in any form.

COPYRIGHT NOTICE:
 The Company and/or our Licensors hold valid copyright in the Software.

ACKNOWLEDGMENT:
 YOU ACKNOWLEDGE THAT YOU HAVE READ THIS AGREEMENT, UNDERSTAND IT AND AGREE TO BE BOUND BY ITS TERMS AND CONDITIONS. YOU ALSO AGREE THAT THIS AGREEMENT IS THE COMPLETE AND EXCLUSIVE STATEMENT OF THE AGREEMENT BETWEEN YOU AND THE COMPANY AND SUPERCEDES ALL PROPOSALS OR PRIOR ENDORSEMENTS, ORAL OR WRITTEN, AND ANY OTHER COMMUNICATIONS BETWEEN YOU AND THE COMPANY OR ANY REPRESENTATIVE OF

THE COMPANY RELATING TO THE SUBJECT MATTER OF THIS AGREEMENT.

[END OF LICENSE AGREEMENT]

Copyright © 2000-2001 Rizal Software Inc.